Incompatible Browser
Friesens MyBooks is only supported using Microsoft Internet Explorer version 5.0 or greater, Firefox 1.0 or greater, or Safari 1.0 or greater. You are attempting to use Generic crawler version 2.

Please upgrade your browser or install one of the latest versions of Internet Explorer, Firefox, or Safari.

We apologize for any inconvenience this may cause.

Friesens MyBooks Web Browser Compatibility

Supported Windows Browsers:

Supported Macintosh Browsers:

Please ensure the following features are enabled in your browser settings:

  • JavaScript
  • Cookies
  • Cascading Style Sheets (CSS)
  • Popup Windows

Recommended Installed Programs:


Friesens MyBooks Web Browser Compatibility

Supported Windows Browsers:

Supported Macintosh Browsers:

Please ensure the following features are enabled in your browser settings:

  • JavaScript
  • Cookies
  • Cascading Style Sheets (CSS)
  • Popup Windows

Recommended Installed Programs: